Tuesday, 2019-06-18

FoxyCart Service Subscription Past Due Data Error

While doing database maintenance, a database query was performed incorrectly, resulting in bad data being written / overwritten to subscriptions' past due amounts, and in some cases the first_failed_transaction_date value.

We are currently working to restore the data. We will post updates here as they are available.

Update 3:20pm PST: We are still working on restoring and correcting data, but all subscriptions without a first_failed_transaction_date have had their past_due_amount values reset to 0 for now.

Update 5:30pm PST: We're prepping to restore the data.

Update 7:50pm PST: All data is restored.