Monday, 2020-03-30

FoxyCart Service Email Delivery Delays

At about 12pm Pacific, Monday March 30, 2020, we became aware of delays in emails being delivered. We are looking into the cause.

UPDATE 1:33pm Pacific: This looks to be an issue with SendGrid.com, whom we use to send emails. Their status page currently doesn't show any issues, but we are working with them to determine the cause.

UPDATE 2:09pm Pacific: We've confirmed this is an issue on the SendGrid.com side of things. Emails appear to be sending in batches rather than immediately. We are working to get it escalated on their end.

UPDATE 2:40pm Pacific: Email delivery has returned to normal. We are continuing to monitor.